Proposal: MailExtensions API to allow UI overlays, but no script injection

Tanstaafl tanstaafl at libertytrek.org
Mon Oct 14 13:32:56 UTC 2019


On 10/10/2019, 5:13:52 PM, John Bieling <john.bieling at gmx.de> wrote:
> And from my current understanding, it should be possible to create a
> general UI overlay API, as it does not create security issues and almost
> no stability issues. So even under the new rules, that should still be
> allowed and thus should be given back to us.

I am totally in favor of this, but...

There should be some stringent tests in place available to AddOn
developers that will allow them to test their Addons against beta/test
builds to determine breakage caused by changes to the underlying/primary
UI, allowing them to adjust their AddOns, or the devs to block the Addon
from being installed in stable builds until it is fixed.

Also there should be a rule governing the kinds of changes that may
break such a UI not be allowed in stable builds without ample
warning/notification, and time given to AddOn devs to fix their AddOns.


More information about the tb-planning mailing list