ATN compatibility data for post-ESR60

Geoff Lankow geoff at thunderbird.net
Wed Jan 23 09:40:43 UTC 2019


Using data scraped from ATN today, I've compiled a list of the 100 
(actually 98) most popular extensions and the compatibility of their 
latest version. I was looking for data on which extensions claim to be 
compatible with post-ESR60 versions, and whether or not they actually 
are. (Only bootstrapped extensions or those with a webextension manifest 
are compatible.) Surprisingly I found as many //which claim to be but 
can't possibly be compatible, as those the claim to be and might be 
compatible.

For those interested in the data I've posted it on Google Docs here:

https://docs.google.com/spreadsheets/d/1rHLzF_7XIaqTgp_paGKQfpen4I3K4SED-ZCeXBfK7Fs/edit?usp=sharing

The picture could be better than it looks. Extension developers might be 
avoiding posting beta-compatible versions due to shortcomings with the 
ATN software. We're gradually trying to get rid of those shortcomings 
(e.g. https://github.com/thundernest/addons-server/pull/58).

GL

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/tb-planning/attachments/20190123/ed2a284d/attachment.html>


More information about the tb-planning mailing list