Renaming ByteArray in TT
stejohns at adobe.com
Tue Jun 17 09:48:42 PDT 2008
Flash Player has a class called ByteArray to allow for efficient
manipulation of raw bytes in ActionScript. This was never implemented in
Tamarin-Central directly, but rather in Flash Player code.
In Tamarin-Tracing, we decided to implement a subset of ByteArray directly
in the VM itself, because (1) it¹s really handy, and (2) the tracing-JIT
design should allow us to make very efficient code for these in many cases
(ie, direct byte access in some cases), and this is a lot easier to do if
the VM can have intimate knowledge of ByteArray.
Unfortunately, this is causing some coding confusion in Flash Player land,
as it means we now have avmplus.ByteArray (the new TT-based class) and
flash.utils.ByteArray (the existing class that Flash already defines).
Despite the separate packages, it¹s causing some coding headaches, so we¹re
thinking that maybe we should rename the new TT-hosted class while it¹s
still new ... the most obvious suggestion (IMHO) being avmplus.ByteVector.
Anyone have suggestions, comments, objections?
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Tamarin-devel