[rust-dev] On Copy = POD
comexk at gmail.com
Sat Jun 21 08:08:29 PDT 2014
On Sat, Jun 21, 2014 at 5:10 AM, Nick Cameron <lists at ncameron.org> wrote:
> I wonder if we could come up with _some_
> design that would be better than the current one.
Could always pave the road to hell and have a short postfix operator.
It would have to be only for cheap clones, but frankly I think those
should have a different method name in any case - it's bad for
readability that '.clone()' could mean either copying an entire vector
or incrementing an integer.
While you're at it, copy Swift's ! operator...
More information about the Rust-dev