[rust-dev] no error or warning when an unknown attribute is used

Ben Harris mail at bharr.is
Wed Jul 16 17:20:56 PDT 2014


Actually, I've just realised this is not the mailing list I thought it was.
I saw the author and my brain said this was the zinc list, not the rust
list. :S


On 17 July 2014 08:16, Ben Harris <mail at bharr.is> wrote:

> Have a quick skim over this (
> http://tomlee.co/2014/04/03/a-more-detailed-tour-of-the-rust-compiler/).
> Lint is the last thing to run before conversion to LLVM.
>
> I'f you like to suggest it changed or augmented, the rust-lang/rust issues
> board would be best.
>
>
> On 16 July 2014 23:15, Ilya Dmitrichenko <errordeveloper at gmail.com> wrote:
>
>> On 16 July 2014 15:23, Chris Morgan <me at chrismorgan.info> wrote:
>> >>> Did it come up as an unused-attribute warning?
>> >> No, it didn't.
>> > The simple reason it doesn't come up as an unknown attribute is
>> > because it did not successfully compile, and so it did not get to the
>> > step where it warns about unused attributes.
>>
>> Sure, it's pretty clear what's going on, but I do think it's a bit of
>> a problem. It's rather hard to spot a misspelled attribute. Should
>> there be a pre-lint stage for this purpose?
>> _______________________________________________
>> Rust-dev mailing list
>> Rust-dev at mozilla.org
>> https://mail.mozilla.org/listinfo/rust-dev
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/rust-dev/attachments/20140717/3895c3dd/attachment.html>


More information about the Rust-dev mailing list