[rust-dev] Deprecating rustpkg

Tony Arcieri bascule at gmail.com
Fri Jan 31 10:14:47 PST 2014


On Fri, Jan 31, 2014 at 10:12 AM, Strahinja Markovic <val at markovic.io>wrote:

> You depend on the latest version of a lib or on a specific, explicit
> version. People who don't care about the old version use the latest, and
> people who need the old lib version because they haven't updated use that.
>

What algorithm do you use to resolve dependencies in a multi-versioned
world?


> This gave me a good, long chuckle (honestly, I mean no offense). Thank
> you, I needed that. My day is already better.
>
> If only I lived in a world where this issue "doesn't come up in
> practice"...
>

#trolololol

(Sorry, that was a typo, I meant to say "this doesn't come up as often as
you allege in practice")

Yes, I too have been dealing with dependency resolution problems for the
past 20 years... but I have also dealt with problems with incompatible
libraries. They both suck.

-- 
Tony Arcieri
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/rust-dev/attachments/20140131/2fcd3d3c/attachment.html>


More information about the Rust-dev mailing list