[rust-dev] rustpkg error: "Package ____ depends on ____, but I don't know how to find it"

Derek Guenther dguenther9 at gmail.com
Wed Jan 29 12:59:10 PST 2014


I'm fairly sure that the problem is with rustpkg. I've never had much
success with rustpkg install. You might be better off using rustc and
makefiles for now, at least until rust's dependency management story
has been solidified.

Hope this helps!

On Wed, Jan 29, 2014 at 2:07 PM, Philippe Delrieu
<philippe.delrieu at free.fr> wrote:
> Thank you for your help. I try, it correct the error but I have other
> message and nothing is generated :
>
> WARNING: The Rust package manager is experimental and may be unstable
> note: Installed package portmidi#0.0 to
> /home/pdelrieu/Documents/dev/musit/workplace_linux/PortMidi/master/rust-portmidi
> task '<unnamed>' failed at 'assertion failed: !outputs_disc.is_empty()',
> /home/pdelrieu/Documents/dev/musit/rust/rust/git/rust/src/librustpkg/util.rs:552
> task '<unnamed>' failed at 'receiving on a closed channel',
> /home/pdelrieu/Documents/dev/musit/rust/rust/git/rust/src/libstd/comm/mod.rs:743
>
> The problem come from rustpkg or my project?
>
> Philippe
>
>
> Le 29/01/2014 15:09, Derek Guenther a écrit :
>
>> I believe the workaround is:
>>
>> extern mod extra = "extra#0.10-pre";
>>
>> It's broken a few builds on rust-ci this week.
>>
>> Derek
>>
>> On Tue, Jan 28, 2014 at 1:43 PM, Philippe Delrieu
>> <philippe.delrieu at free.fr> wrote:
>>>
>>> Any info or idea?
>>> I update from the master and now all my project have the same issue.
>>> If I use rustc I have no problem. I see the thread about rustpkg, perhaps
>>> I
>>> should migrate to rustc and cmake?
>>>
>>> Philippe
>>>
>>> Le 26/01/2014 16:25, Philippe Delrieu a écrit :
>>>
>>> Hi,
>>>
>>> I have the same problem since 2 or 3 days with the portmidi project.
>>>
>>> Philippe
>>>
>>> Le 26/01/2014 14:06, Cadence Marseille a écrit :
>>>
>>> Hi,
>>>
>>> I am seeing a new build error and I am not sure what is causing it.
>>> rust-pcre, libpcre bindings for Rust, is set up to use Travis and Rust
>>> CI.
>>> The latest build is failing with:
>>>
>>> rustpkg install pcre
>>>
>>> WARNING: The Rust package manager is experimental and may be unstable
>>>
>>> error: Package pcre depends on extra, but I don't know how to find it
>>>
>>> task '<unnamed>' failed at 'explicit failure',
>>>
>>> /build/buildd/rust-nightly-201401260405~897a0a3~precise/src/librustpkg/util.rs:531
>>>
>>> task '<main>' failed at 'receiving on a closed channel',
>>>
>>> /build/buildd/rust-nightly-201401260405~897a0a3~precise/src/libstd/comm/mod.rs:743
>>>
>>> task '<unnamed>' failed at 'Error running custom build command',
>>>
>>> /build/buildd/rust-nightly-201401260405~897a0a3~precise/src/librustpkg/lib.rs:517
>>>
>>> make: *** [install] Error 65
>>>
>>>
>>> See https://travis-ci.org/cadencemarseille/rust-pcre/builds/17643218
>>>
>>> I looked at some other Rust CI-enabled projects and found a similar
>>> error:
>>> https://travis-ci.org/eholk/rust-opencl/builds/17491630
>>> https://travis-ci.org/erickt/rust-zmq/builds/16353359
>>> https://travis-ci.org/erickt/rust-mustache/builds/16059551
>>> https://travis-ci.org/bjz/gl-rs/builds/16126945
>>> https://travis-ci.org/bjz/sax-rs/builds/16405581
>>>
>>> What is causing this error and how do I fix it?
>>>
>>> Cadence
>>>
>>>
>>> _______________________________________________
>>> Rust-dev mailing list
>>> Rust-dev at mozilla.org
>>> https://mail.mozilla.org/listinfo/rust-dev
>>>
>>>
>>>
>>>
>>> _______________________________________________
>>> Rust-dev mailing list
>>> Rust-dev at mozilla.org
>>> https://mail.mozilla.org/listinfo/rust-dev
>>>
>>>
>>>
>>> _______________________________________________
>>> Rust-dev mailing list
>>> Rust-dev at mozilla.org
>>> https://mail.mozilla.org/listinfo/rust-dev
>>>
>>
>
> _______________________________________________
> Rust-dev mailing list
> Rust-dev at mozilla.org
> https://mail.mozilla.org/listinfo/rust-dev


More information about the Rust-dev mailing list