[rust-dev] RFC: New Rust channel proposal

Benjamin Striegel ben.striegel at gmail.com
Thu Jan 23 19:29:24 PST 2014


This all seems a bit silly. A channel *is*, conceptually, a tuple of a
sender and a receiver. If I call Chan::new(), that's what I expect to get.
And Chan::open() doesn't map to anything that's as intuitive.

Is naming really all that's left to argue about? How does everyone feel
about the semantics of the proposal?


On Thu, Jan 23, 2014 at 10:20 PM, Strahinja Markovic <val at markovic.io>wrote:

>
> On Thu Jan 23 2014 at 7:18:11 PM, Tony Arcieri <bascule at gmail.com> wrote:
>
>> I have a crazy idea...
>>
>> Channel::open()
>>
>
> That's a better name for the function, agreed.
>
>
>>
>>
>> https://lh3.ggpht.com/-WpuYGqCEHDg/UBznzaqReKI/AAAAAAAAB_0/0Vc8_mnnhqw/s1600/mind-blown.gif
>>
>> --
>> Tony Arcieri
>>
>
> _______________________________________________
> Rust-dev mailing list
> Rust-dev at mozilla.org
> https://mail.mozilla.org/listinfo/rust-dev
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/rust-dev/attachments/20140123/f492234d/attachment.html>


More information about the Rust-dev mailing list