[rust-dev] RFC: New Rust channel proposal

Thad Guidry thadguidry at gmail.com
Thu Jan 23 13:28:32 PST 2014


On Thu, Jan 23, 2014 at 2:33 PM, Brian Anderson <banderson at mozilla.com>wrote:

> On 01/13/2014 10:15 PM, Liigo Zhuang wrote:
>
>> People should rethink the Chan api that Chan::new() does not returns a
>> value of type Chan (instead, a tuple), which is strange, and inconsistent
>> with other Type::new().
>>
>>
> Agree, though I haven't heard any great suggestions yet. The core problem
> is that there are three different entities involved: the sending end, the
> recieving end, and the thing that represents the entire channel, and they
> all need different names. The best I've heard is `pipe() -> (Port, Chan)`,
> but I would rather call the whole thing a channel and have a different name
> for the sender.
>
>
A good alias / synonym for a "sender" would be a "transmitter".  food for
thought.

-- 
-Thad
+ThadGuidry <https://www.google.com/+ThadGuidry>
Thad on LinkedIn <http://www.linkedin.com/in/thadguidry/>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/rust-dev/attachments/20140123/0ca72225/attachment.html>


More information about the Rust-dev mailing list