[rust-dev] RFC: New Rust channel proposal

Brian Anderson banderson at mozilla.com
Thu Jan 23 12:33:27 PST 2014

On 01/13/2014 10:15 PM, Liigo Zhuang wrote:
> People should rethink the Chan api that Chan::new() does not returns a 
> value of type Chan (instead, a tuple), which is strange, 
> and inconsistent with other Type::new().

Agree, though I haven't heard any great suggestions yet. The core 
problem is that there are three different entities involved: the sending 
end, the recieving end, and the thing that represents the entire 
channel, and they all need different names. The best I've heard is 
`pipe() -> (Port, Chan)`, but I would rather call the whole thing a 
channel and have a different name for the sender.

More information about the Rust-dev mailing list