[rust-dev] Rust 0.7 prerelease testing

Vadim vadimcn at gmail.com
Wed Jul 3 14:26:14 PDT 2013


Looks like MinGW's "libpthread-2.dll" got renamed to
"pthreadGC2.dll"<http://permalink.gmane.org/gmane.comp.gnu.mingw.devel/4249>at
some point.   So Rust 0.7 won't work with a fresh MinGW installation
unless users downgrade libpthread to v2.8 (mingw-get upgrade
"libpthread=2.8.0-3").

However, previous Rust releases had used libpthread v2.9, so, perhaps, this
change wasn't intentional?



On Wed, Jul 3, 2013 at 12:12 AM, Vijay Korapaty <rustdevlist at korapaty.com>wrote:

> Ran the installer on Windows 7 (64-bit) and came across 2 problems so far.
>
> The first was when trying the 'rustc' command from cmd.exe, I got an error
> 'libpthread-2.dll is not found'. If tried in PowerShell, there is no output
> or error, just a new prompt. Following the 'Troubleshooting Windows
> environment setups' section here https://github.com/mozilla/**
> rust/wiki/Note-getting-**started-developing-Rust<https://github.com/mozilla/rust/wiki/Note-getting-started-developing-Rust>,
> and dumping the dll into the Rust installation directory (C:\Program
> Files(x86)\Rust\bin) fixed that error.
>
> (I would note that I have no idea where that lzma command line program
> mentioned in the Notes page comes from. Tried
> http://www.7-zip.org/sdk.html that, and that was a rabbit hole of
> confusion. It was much simpler to use the 7-zip GUI to extract the dll from
> the .tar.lzma package.)
>
> The second problem is with 'rusti', https://github.com/mozilla/**
> rust/issues/7499 <https://github.com/mozilla/rust/issues/7499> was
> happening for me.
> ______________________________**_________________
> Rust-dev mailing list
> Rust-dev at mozilla.org
> https://mail.mozilla.org/**listinfo/rust-dev<https://mail.mozilla.org/listinfo/rust-dev>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/rust-dev/attachments/20130703/c5c6acbc/attachment.html>


More information about the Rust-dev mailing list