[rust-dev] Proposal: rename sequence concatenation operator to ++

Joe Groff arcata at gmail.com
Wed Jan 25 12:42:19 PST 2012


On Wed, Jan 25, 2012 at 12:18 PM, Marijn Haverbeke <marijnh at gmail.com> wrote:
> That works, but doesn't provide the conceptual simplicity of a number
> interface, and if you want to write a generic over any numeric type,
> it could end up taking a <T: add, mult, sub, div> type parameter.

It might be foolish simplicity in this case. How hard/theoretically
sound would it be to support iface multiple inheritance, so you can
have your 'num' typeclass be a subclass of add, mul, sub, div? And how
about separating the integer quotient from field division ifaces,
since they're different operations, and a routine written for one
likely won't work for the other?

-Joe


More information about the Rust-dev mailing list