[rust-dev] Proposal: rename sequence concatenation operator to ++

Patrick Walton pwalton at mozilla.com
Wed Jan 25 12:13:05 PST 2012

On 1/25/12 11:46 AM, Marijn Haverbeke wrote:
> Currently it is simply '+'.
> The thing that prompted this is issue #1520 -- operator overloading.
> Delegating + on non-builtin-numeric types to a `num` interface that
> implements methods add/sub/mult/div/rem/neg methods seems elegant, and
> similar to Haskell's approach. Vector-concatenation + messes
> everything up though, since vectors can't meaningfully implement the
> full num interface.

What about an add interface?


More information about the Rust-dev mailing list