[rust-dev] RFC: "impl Trait for Type"
colin.mailinglist at gmail.com
Mon Dec 31 14:17:00 PST 2012
As a (very) new user of Rust, I would definitely have found this confusing.
I think the proposal makes it much clearer what is happening, and I think
that reusing 'impl' is fine - the two 'impl' forms are sufficiently
different to avoid any confusion.
On 1 January 2013 05:54, Patrick Walton <pwalton at mozilla.com> wrote:
> On 12/31/12 3:05 AM, Gareth Smith wrote:
>> Because they both start with the same keyword. Though perhaps this is
>> not significant.
> Agreed, I considered this. There are a couple of reasons why I didn't
> propose a different keyword:
> 1. Rust tries hard to reuse keywords in general, since everyone likes a
> small set of keywords.
> 2. I didn't really like any of the obvious options. The most obvious
> keyword to switch to would be "inst" to mirror Haskell and so forth, but is
> "impl"/"inst" really less confusing? I suspect many programmers would want
> to "implement" a trait and would choose "impl".
> Rust-dev mailing list
> Rust-dev at mozilla.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Rust-dev