[rust-dev] 0.5 prerelease testing

Graydon Hoare graydon at mozilla.com
Thu Dec 20 19:47:48 PST 2012


On 12-12-20 07:42 PM, James Gao wrote:
> Confirm the problem here is caused by incompatible version of
> libstdc++-6.dll, I copy an old version libstdc++-6.dll, then rustc works
> fine.
> 
> Can we pack the correct libstdc++-6.dll in the installer and stage0
> snapshot packages?

I'm afraid not, not presently. We've struggled with this issue in
previous releases and attempted to be as explicit as possible about
dependencies on mingw in the meantime. We will be fixing it when we can.
It bites us every single time.

Thanks for your testing though.

-Graydon




More information about the Rust-dev mailing list