[rust-dev] OCaml 3.12 ?

Peter Hull peterhull90 at gmail.com
Sun Oct 10 13:23:50 PDT 2010


I've suddenly started getting compile errors for rustboot and I think
it was after I updated OCaml to 3.12 (via 'port upgrade outdated').
What I see is,

compile: boot/fe/cexp.ml
File "boot/fe/cexp.ml", line 347, characters 15-24:
Warning 9: the following labels are not bound in this record pattern:
id
Either bind these labels explicitly or add `; _' to the pattern.
File "boot/fe/cexp.ml", line 361, characters 15-24:
Warning 9: the following labels are not bound in this record pattern:
id
Either bind these labels explicitly or add `; _' to the pattern.
File "boot/fe/cexp.ml", line 1, characters 0-1:
Error: Error-enabled warnings (2 occurrences)
make: *** [boot/fe/cexp.cmx] Error 2

Is this something that changed in OCaml?

Pete


More information about the Rust-dev mailing list