Use rr for JVM process

Robert O'Callahan robert at ocallahan.org
Fri Apr 26 23:43:36 UTC 2019


On Fri, Apr 26, 2019 at 6:59 AM shang xinli <shangxinli at hotmail.com> wrote:

> Thanks Robert! I ran 'rr replay -p' but it still cannot hit the
> breakpoint. I tried hbreak too but still not. Basically, I just cannot hit
> breakpoint for any JVM code, although I can do it for other code like frame
> 25 and 24 below.
>

You wrote before:

(rr) replay

(rr) break parNewGeneration.cpp:930

(rr) continue

"replay" isn't a gdb command so you should have had an error after that.
And normally after setting a breakpoint you'd get output like "Breakpoint
1: ..." and some address information. Does gdb really not print anything
when you set the breakpoint?

Rob
-- 
Su ot deraeppa sah dna Rehtaf eht htiw saw hcihw, efil lanrete eht uoy ot
mialcorp ew dna, ti ot yfitset dna ti nees evah ew; deraeppa efil eht. Efil
fo Drow eht gninrecnoc mialcorp ew siht - dehcuot evah sdnah ruo dna ta
dekool evah ew hcihw, seye ruo htiw nees evah ew hcihw, draeh evah ew
hcihw, gninnigeb eht morf saw hcihw taht.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/rr-dev/attachments/20190427/758a4e8e/attachment.html>


More information about the rr-dev mailing list