回复: Use rr for JVM process

shang xinli shangxinli at hotmail.com
Tue Apr 23 03:55:56 UTC 2019


Can rr be installed on "Debian GUN/Linux"? I hit the following problem when installing it.


sudo rpm -ivh rr-5.2.0-Linux-x86_64.rpm


rpm: RPM should not be used directly install RPM packages, use Alien instead!

rpm: However assuming you know what you are doing...

error: Failed dependencies:

/usr/bin/bash is needed by rr-5.2.0-1.x86_64

libc.so.6()(64bit) is needed by rr-5.2.0-1.x86_64

libc.so.6(GLIBC_2.11)(64bit) is needed by rr-5.2.0-1.x86_64

libc.so.6(GLIBC_2.13)(64bit) is needed by rr-5.2.0-1.x86_64

libc.so.6(GLIBC_2.14)(64bit) is needed by rr-5.2.0-1.x86_64

libc.so.6(GLIBC_2.2.5)(64bit) is needed by rr-5.2.0-1.x86_64

libc.so.6(GLIBC_2.3)(64bit) is needed by rr-5.2.0-1.x86_64

libc.so.6(GLIBC_2.3.4)(64bit) is needed by rr-5.2.0-1.x86_64

libc.so.6(GLIBC_2.4)(64bit) is needed by rr-5.2.0-1.x86_64

libc.so.6(GLIBC_2.8)(64bit) is needed by rr-5.2.0-1.x86_64

libc.so.6(GLIBC_2.9)(64bit) is needed by rr-5.2.0-1.x86_64

libdl.so.2()(64bit) is needed by rr-5.2.0-1.x86_64

libdl.so.2(GLIBC_2.2.5)(64bit) is needed by rr-5.2.0-1.x86_64

libgcc_s.so.1()(64bit) is needed by rr-5.2.0-1.x86_64

libgcc_s.so.1(GCC_3.0)(64bit) is needed by rr-5.2.0-1.x86_64

libgcc_s.so.1(GCC_3.4)(64bit) is needed by rr-5.2.0-1.x86_64

libm.so.6()(64bit) is needed by rr-5.2.0-1.x86_64

libm.so.6(GLIBC_2.2.5)(64bit) is needed by rr-5.2.0-1.x86_64

libpthread.so.0()(64bit) is needed by rr-5.2.0-1.x86_64

libpthread.so.0(GLIBC_2.12)(64bit) is needed by rr-5.2.0-1.x86_64

libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by rr-5.2.0-1.x86_64

libpthread.so.0(GLIBC_2.3.2)(64bit) is needed by rr-5.2.0-1.x86_64

librt.so.1()(64bit) is needed by rr-5.2.0-1.x86_64

librt.so.1(GLIBC_2.2.5)(64bit) is needed by rr-5.2.0-1.x86_64

libstdc++.so.6()(64bit) is needed by rr-5.2.0-1.x86_64

libstdc++.so.6(CXXABI_1.3)(64bit) is needed by rr-5.2.0-1.x86_64

libstdc++.so.6(CXXABI_1.3.5)(64bit) is needed by rr-5.2.0-1.x86_64

libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by rr-5.2.0-1.x86_64

libstdc++.so.6(GLIBCXX_3.4.11)(64bit) is needed by rr-5.2.0-1.x86_64

libstdc++.so.6(GLIBCXX_3.4.14)(64bit) is needed by rr-5.2.0-1.x86_64

libstdc++.so.6(GLIBCXX_3.4.15)(64bit) is needed by rr-5.2.0-1.x86_64

libstdc++.so.6(GLIBCXX_3.4.18)(64bit) is needed by rr-5.2.0-1.x86_64

libstdc++.so.6(GLIBCXX_3.4.9)(64bit) is needed by rr-5.2.0-1.x86_64

rtld(GNU_HASH) is needed by rr-5.2.0-1.x86_64



发送自 Outlook<http://aka.ms/weboutlook>

________________________________
发件人: Robert O'Callahan <robert at ocallahan.org>
发送时间: 2019年4月22日 14:17
收件人: shang xinli
抄送: rr-dev at mozilla.org
主题: Re: Use rr for JVM process

On Tue, Apr 23, 2019 at 3:45 AM shang xinli <shangxinli at hotmail.com<mailto:shangxinli at hotmail.com>> wrote:
Have anybody use rr to record JVM application execution? Does it work?

I have heard that it works. I haven't done it myself.

Rob
--
Su ot deraeppa sah dna Rehtaf eht htiw saw hcihw, efil lanrete eht uoy ot mialcorp ew dna, ti ot yfitset dna ti nees evah ew; deraeppa efil eht. Efil fo Drow eht gninrecnoc mialcorp ew siht - dehcuot evah sdnah ruo dna ta dekool evah ew hcihw, seye ruo htiw nees evah ew hcihw, draeh evah ew hcihw, gninnigeb eht morf saw hcihw taht.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/rr-dev/attachments/20190423/eb3af7fa/attachment-0001.html>


More information about the rr-dev mailing list