rr on oracle linux 6

Kyle Huey me at kylehuey.com
Tue Nov 1 00:44:43 UTC 2016


On Mon, Oct 31, 2016 at 5:39 PM, Benjamin Dicken <bddicken at gmail.com> wrote:
> All,
>
> Has anyone tested rr on or gotten rr to work on oracle-linux 6? I am
> currently trying to do so but running into a lot of problems. I tried both
> building from source and installing via the rpm package. For both, I have
> run into a lot of snags: Missing dependencies, compilation warnings/errors,
> missing headers, etc. Some of the specific ones I am currently facing may
> not be easy to resolve or work around given my version and other
> restrictions.
>
> Just wanted to check: Has anyone accomplished this before? If so, are there
> instructions out there on how to do so?
>
> My exact version of OEL is:
>
> $ rpm -qf /etc/redhat-release
> oraclelinux-release-6Server-8.0.3.x86_64
>
> Thanks,
>
> --
> ~Benjamin Dicken

Which kernel version are you running?  rr requires at least 3.4, and
RHEL 6 is using 2.6.32, so unless Oracle is shipping you a more up to
date kernel you may be out of luck.

- Kyle


More information about the rr-dev mailing list