Buildling for other platforms

Robert O'Callahan robert at ocallahan.org
Fri Oct 23 22:14:06 UTC 2015


On Sat, Oct 24, 2015 at 10:52 AM, Uri Moszkowicz <uri at 4refs.com> wrote:

> Hi guys,
> I know it's not explicitly supported but has anyone looked at building RR
> for RHEL/SUSE? I tried on RHEL5 and after buildling cmake it was
> complaining about missing zlib, which I also built but don't know hot to
> specify to cmake.
>

You should just be able to install a zlib-devel package and cmake will pick
it up automatically.

I tried with RHEL6 next and it complains about an insufficient python
> version. I added the newer python version to PATH but CMake still doesn't
> seem to be picking it up.
>
> Do you all know how to specify paths to dependencies with CMake? Usually
> I'd see options from configure. Am I going down a rat hole here or is it
> likely to be builable on RHEL4-6 and SUSE10-11?
>

It shouldn't be hard to fix the build issues. I'm not a cmake expert either
so I can't tell you what to do off the top of my head.

The deal-breaker, if any, will be the kernel version. rr requires
seccomp-bpf for reasonable performance. If your kernel doesn't have that,
rr is much less useful. You will probably find other issues with even older
kernels.

Rob
-- 
lbir ye,ea yer.tnietoehr  rdn rdsme,anea lurpr  edna e hnysnenh hhe uresyf
toD
selthor  stor  edna  siewaoeodm  or v sstvr  esBa  kbvted,t
rdsme,aoreseoouoto
o l euetiuruewFa  kbn e hnystoivateweh uresyf tulsa rehr  rdm  or rnea
lurpr
.a war hsrer holsa rodvted,t  nenh hneireseoouot.tniesiewaoeivatewt sstvr
esn
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/rr-dev/attachments/20151024/8e2cfea7/attachment.html>


More information about the rr-dev mailing list