rr refactorings

Chris Jones jones.chris.g at gmail.com
Mon Apr 21 21:08:23 PDT 2014

On Mon, Apr 21, 2014 at 8:40 PM, Robert O'Callahan <robert at ocallahan.org>wrote:

> On Tue, Apr 22, 2014 at 3:20 PM, Chris Jones <jones.chris.g at gmail.com>wrote:
>> (I might bikeshed |remote<T>| for brevity and ​avoiding potential
>> ambiguity around "task".)
> Sounds good. remote or Remote? What are our naming conventions? :-)
You mean currently?  Whoever writes the patch :).  We should fix that ...​

​I prefer Foo for what you might call "noun" types (class Task), and foo
for what you might call "adjective" types (shared_ptr<Task>).  I don't have
a more precise way of expressing that at hand.

 ​That sounds fine, but one issue I'd point out is that even for the same
>> arch, both 32-bit and 64-bit variants of structs can be used.  For example,
>> on x86, |fcntl64(GETLK, struct flock)| works, and so does
>> |fcntl64(GETLK64(, struct flock64)|.  There's really not an elegant
>> solution for that, but it feels a little awkward to name those variants by
>> architecture when they're just different off_t widths.  I'm not proposing
>> anything, just pointing that out :).
> I think the best solution depends on whether, on x86-64, the kernel's
> struct flock uses 32-bit or 64-bit offsets.

​That's a good question.  I'm pretty sure 64-bit.​

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/rr-dev/attachments/20140421/b0691f8a/attachment.html>

More information about the rr-dev mailing list