Change to Linux Native Accessibility Support

Josh Aas josh at mozilla.com
Thu Apr 29 10:36:44 PDT 2010


Sounds good, Mozilla will be adding support for NPPVpluginNativeAccessibleAtkPlugId with a value of 19 if there are no objections.

--
Josh Aas
Software Engineer
Mozilla Corporation

----- Original Message -----
From: "Brad Taylor" <brad at getcoded.net>
To: plugin-futures at mozilla.org
Sent: Thursday, April 29, 2010 1:20:09 PM
Subject: Change to Linux Native Accessibility Support

Hey all,

As Firefox's support for Out of Process plugin accessibility support on
Linux[1] comes closer to fruition[2], we've made a few minor changes to
the API to better comply with the current state of NPAPI.  Since this
was unimplemented API, I'm hoping these changes won't be too much of an
inconvenience.

The changes:

* NPPNativeAccessibleAtkPlugId has been changed to
  NPPVpluginNativeAccessibleAtkPlugId
* NPPVpluginNativeAccessibleAtkPlugId now has the ID of 19

All of these modifications are now reflected in NativeAccessibility wiki
page[1].

Best,

-Brad

--
[1] https://wiki.mozilla.org/NPAPI:NativeAccessibility
[2] https://bugzilla.mozilla.org/show_bug.cgi?id=480317

_______________________________________________
plugin-futures mailing list
plugin-futures at mozilla.org
https://mail.mozilla.org/listinfo/plugin-futures


More information about the plugin-futures mailing list