New language features in Android SDK tools 22.6

Richard Newman rnewman at mozilla.com
Thu May 22 15:46:30 PDT 2014


From the release notes:

"Added support for Java 7 language features like multi-catch, try-with-resources, and the diamond operator. These features require version 19 or higher of the Build Tools. Try-with-resources requires minSdkVersion 19; the rest of the new language features require minSdkVersion 8 or higher."

I know that some folks have been waiting for the SDK to catch up to JDK7, so this should be welcome news.


More information about the mobile-firefox-dev mailing list