[ann] android-17 now required for building

Nick Alexander nalexander at mozilla.com
Wed May 14 08:33:52 PDT 2014


Hi m-f-d,

Sorry for the late notice, but Android platform SDK 17 is now required 
for building.  We've been on 17 on the buildbots for a while, but now 
that Bug 917480 [1] has landed we require 17 everywhere.  The error 
you'll see if you build with a version previous to 17 is like

AndroidManifest.xml:123: error: Error: String types not allowed (at 
'configChanges' with value ...

and was filed as Bug 1010281 [2].  I've marked that RESO INVALID since 
we really want rnewman's locale switching feature.

Again, sorry for bustage,
Nick

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=917480

[2] https://bugzilla.mozilla.org/show_bug.cgi?id=1010281


More information about the mobile-firefox-dev mailing list