<div dir="ltr"><div>FYI, the VC++ 2017 v14.12 toolset included in the recently-released VS2017 15.5 update appears to have broken building Firefox due to issues with the Rust compiler (in particular, the version of libclang we ship with it) and one of the system headers:</div><div><br></div><div>C:\PROGRA~2\MIB055~1\2017\COMMUN~1\VC\Tools\MSVC\1412~1.258\include\type_traits:898:47:
 error: '_Ty' does not refer to a value</div><div><br></div><div>Which in turns leads to a Rust panic and build failure.</div><div><br></div><div>The Visual Studio installer allows you to install the prior v14.11 toolset as well, but I haven't verified yet that our build system will properly use it if it's there. In the mean time, I'd strongly advise avoiding this update until it's sorted out.</div><div><br></div><div>-Ryan<br></div></div>