Firefox configure error: libffi > 3.0.9

Justin Dolske dolske at mozilla.com
Wed Mar 22 01:04:52 UTC 2017


>From a quick skim, it looks like we default to the system-installed libffi
on non-tier-1 systems (like ppc64), and otherwise use the in-tree version
of libffi.

See https://dxr.mozilla.org/mozilla-esr52/source/js/ffi.configure#9-20

Justin

On Tue, Mar 21, 2017 at 4:56 PM, Charles G Robertson <cgrobertson at suse.com>
wrote:

> Hi,
>
> I am building Firefox 52.0 ESR on different architectures: x86_64 and
> ppc64.  It works on x86 but fails on ppc64 with the following configure
> error:
>
>  checking for libffi > 3.0.9... no
>  ERROR: Requested 'libffi > 3.0.9' but version of libffi is 3.0.9
>
> When comparing the two builds the installed version of libffi on both x86
> and ppc is 3.0.9. In fact, there is NO check for libffi > 3.0.9 on x86 that
> I can see in the config.log file.
>
> Why then would it build on x86 and not ppc?
>
> Is there some other Firefox dependency that depends on libffi > 3.0.9 that
> I'm not aware of that may be unique to ppc?
>
> Any help is greatly appreciated.
>
> Thanks
> Cheers
>   Charles Robertson
>   Firefox Maintainer
>   SUSE
>
> _______________________________________________
> firefox-dev mailing list
> firefox-dev at mozilla.org
> https://mail.mozilla.org/listinfo/firefox-dev
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/firefox-dev/attachments/20170321/8390174a/attachment.html>


More information about the firefox-dev mailing list