<div dir="ltr">> Every language feature adds cognitive overhead. It is not something that can or should be avoided. It should be minimized and balanced against other factors.<div><br></div><div>True, though I'd still argue that adding a new way to generate a function without either instantiating a function (with "()") or calling a function (with "()") </div><div><br></div><div>So - I get what you're saying.  </div><div><br></div><div>As for how ".p" looks like a variable assignment, I mean specifically that it *doesn't* look like a function assignment (which it is) and looks more like a value assignment (which it isn't.) Granted, it doesn't 100% look like *either*.  And yes, while companies can choose to not allow it in their own style guides, making it part of the language means that a user may encounter it, especially if they're trying to figure out how imported code works (not to mention, not every programmer in a company follows - or even reads - the styleguide.) </div><div><br></div><div>If I *had* to have this functionality in the language (and by no means have I ever had any problem with "const foo = x => x.prop;") it would be better to define a new keyword that more explicitly explains the purpose.  </div><div><br></div><div>```</div><div>(window || global).propDriller = function(arrayOfProperties, defaultReturn) {<br>  const driller = function(parameter, arrayOfProperties, defaultReturn) {<br>    let working = parameter;<br>    if (arrayOfProperties.length === 0) {<br>      return working;<br>    }<br>    if (working === undefined || !(working instanceof Object)) {<br>      return defaultReturn;<br>    }<br>    return driller(working[arrayOfProperties[0], arrayOfProperties.slice(1), defaultReturn)<br>    }<br>  }<br>  return function(parameter) {<br>    return driller(parameter, arrayOfProperties, defaultReturn)<br>  }<br>}<br></div><div><br></div><div><div>const getEmail = propDriller(['user', 0, "email'], defaultReturn)</div><div><br></div></div><div>```<br></div><div><br></div><div><br></div><div>I'd have no objection to this whastsoever (and the above could be used as a polyfill). But again, this is<i> </i>something that I think is a bit of a niche use case. </div></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Sun, Jun 23, 2019 at 11:01 AM Bob Myers <<a href="mailto:rtm@gol.com">rtm@gol.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div dir="ltr">Every language feature adds cognitive overhead. It is not something that can or should be avoided. It should be minimized and balanced against other factors.<div><br></div><div>Whether some codebase uses the new ```.prop``` syntax, or ```R.pick``` (from Ramda), or ```pluck("p")```. from RxJS, or some third-party or homegrown utility, the programmer will have to learn it. For such a common use case, it's better to have one thing for everyone to learn. Even then, as with most other features, people could choose not to use it, or a company could disallow its use in their styleguide if they really felt strongly enough about it.</div><div><br></div><div>> The problem with the proposal, as I see it, is that it creates a function that looks, at first glance, to be a variable assignment. </div><div><br></div><div>I don't understand this objection. How does ```.p```, which is the notation we are talking about, look like a variable assignment? </div><div><br></div><div>As mentioned earlier in the thread, if there is concern that the leading dot is easy to overlook--which I don't think is the case, and is less of a problem in any case in most editors using monospaced fonts--there are myriad alternatives, including any non-unary operator such as ```^```, some unique combination of symbols, a keyword such as `pick`, or ```?.` where the ```?``` can be read as a placeholder for an object to be passed in later. The proposal by no means rides on the specific symbol or notation chosen. The advantage of the dot is that it is the long-established notation for property access. We are merely extending that notion by assigning a different meaning when the expression on the left is omitted.</div><div><br></div><div><br></div></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Sun, Jun 23, 2019 at 2:31 AM Brian Boyko <<a href="mailto:brian.boyko@gmail.com" target="_blank">brian.boyko@gmail.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div dir="ltr">Howdy. First post to es-discuss. <br><br>I've been thinking about the proposal.  I would recommend against it, main reason being that it makes the language a bit harder to read and understand at-a-glance.  <br><br>Here's why. As an example, you've listed <br><br>```const getEmail = .contacts.email;```<br><br>as a possible use case. The problem with this is that what you're essentially doing is adding a *third* way to write a function (other than "const foo = x => x" or "function foo (x) { return x }"<br><br>Now, I don't mind the arrow operator since it automatically binds "this" and makes tracking the scope of "this" easier (as well as making "this" behave more like an object-oriented programmer coming from a primarily OOP language would expect "this" to behave). Trick is, of course that in so doing, we've added a "special occasion" where if we *do* need the function to have it's own "this" scope, we need to use the longer syntax. That "=>" is shorter to type encourages it's use as the default, and when a coder looks at someone writing out "function" it warns them that something funky is about to happen with "this."<br><br>The problem with the proposal, as I see it, is that it creates a function that looks, at first glance, to be a variable assignment. Granted, that leading "." does look different from most variable assignments, but it's easy to overlook. Whether it's with an arrow function or the function keyword, when a function is defined, it is always defined with "()" somewhere in it. It is, in fact, what makes functions *look different* at a skim-level of reading comprehension, from things like assignments and operations.<br><br>By adding this new way of writing functions without () in the syntax, you increase the cognitive overhead of the programmer, which is something we want to avoid.<br><br>A concise programming language is not a programming language with the fewest characters, but the programming language with the fewest characters *necessary to make meaning clear.* I just don't think that the proposed syntax clearly indicates what it does, and violates the principle of least surprise.<br><br>So - that's my two cents as a person who isn't a language *expert* perse but does have to use ES on a daily basis.<div><br></div><div>It's still a good problem to solve, though, as (x) => x.some.property does come up quite often.  But perhaps this should be a proposal in a helper library like lodash that isn't something that all javascript programmers learning the language need to internalise. That way you could write: </div><div><br></div><div>const getEmail = _.drill("contacts.email", value_if_undefined) </div><div>or</div><div>const getEmail = _.drill(['contacts', 'email'], value_if_undefined)</div><div><br></div><div>get nearly the same amount of code golf, and be able to use it when you need it.  </div><div><br></div></div>
_______________________________________________<br>
es-discuss mailing list<br>
<a href="mailto:es-discuss@mozilla.org" target="_blank">es-discuss@mozilla.org</a><br>
<a href="https://mail.mozilla.org/listinfo/es-discuss" rel="noreferrer" target="_blank">https://mail.mozilla.org/listinfo/es-discuss</a><br>
</blockquote></div>
</blockquote></div>