<div id="reply-content"><br></div>
     
    <p style="color: #A0A0A8;">On Sunday, August 26, 2012 at 7:30 PM, Brendan Eich wrote:</p>
    <blockquote type="cite" style="border-left-style:solid;border-width:1px;margin-left:0px;padding-left:10px;">
        <div id="quoted-message-content"><div><div>Rick Waldron wrote:</div><blockquote type="cite"><div><blockquote type="cite"><div>But Array.of is not. Maybe Array.new is a good name.</div></blockquote><div>Array.of is unambiguous with the current ES specification</div></div></blockquote><div><br></div><div>Array.new is ok too, though -- no problem with a reserved identifier as </div><div>a property name. It's darn nice for Rubyists.</div><div><br></div><div>OTOH Array.of matches the preposition pattern used in Array.from. But I </div><div>don't think this trumps Array.new. </div></div></div></blockquote><div><br></div><div>Nor do I, but I think it poses a problem for polyfilling (which is not a silver bullet).</div><div><br></div><div>+1 Array.new, but I still think Array.of sounds, feels and looks nicer</div><div><br></div><div>Rick</div><blockquote type="cite" style="border-left-style:solid;border-width:1px;margin-left:0px;padding-left:10px;"><div id="quoted-message-content"><div><div>Cc'ing Dave for his thoughts.</div><div><br></div><div>/be</div></div></div>
         
         
         
         
    </blockquote>
     
    <div>
        <br>
    </div>