String identity template tag
andrea.giammarchi at gmail.com
Thu Dec 13 12:44:49 UTC 2018
FWIW, I've used same logic for something like a no-op for i18n`strings` 
so, considering it has easily use cases with mapped interpolations too, I
think it's more than natural to have that in core.
It's also backward compatible/polyfillable so this is kinda a no-brainer,
name a part, of course.
On Thu, Dec 13, 2018 at 6:15 PM T.J. Crowder <
tj.crowder at farsightsoftware.com> wrote:
> In general, I think method names should be verbs in the imperative
> tense (okay, *mood* if you like linguistic distinctions), which would
> argue for `cook` rather than `cooked`. (`String.raw` is an unfortunate
> exception to this rule, which has largely been used throughout the
> standard library. Another exception is `Reflect.ownKeys`. There are
> probably others as well, but they are exceptions, not the norm.)
> I like `cook`. It's `assemble`, but with more flavor.
> The good news here, though, is we're all talking about a name, which
> suggests that in general people like the taste of the idea. There
> don't seem to be concerns that it's half-baked.
> (I'll stop now.)
> -- T.J. Crowder
> es-discuss mailing list
> es-discuss at mozilla.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the es-discuss