String identity template tag
tj.crowder at farsightsoftware.com
Thu Dec 13 10:15:01 UTC 2018
In general, I think method names should be verbs in the imperative
tense (okay, *mood* if you like linguistic distinctions), which would
argue for `cook` rather than `cooked`. (`String.raw` is an unfortunate
exception to this rule, which has largely been used throughout the
standard library. Another exception is `Reflect.ownKeys`. There are
probably others as well, but they are exceptions, not the norm.)
I like `cook`. It's `assemble`, but with more flavor.
The good news here, though, is we're all talking about a name, which
suggests that in general people like the taste of the idea. There
don't seem to be concerns that it's half-baked.
(I'll stop now.)
-- T.J. Crowder
More information about the es-discuss