Math.roundUp(), an alias for Math.ceil()
robjtede at icloud.com
Sat Aug 4 23:04:19 UTC 2018
From my experience, folks don’t like adding things to the spec that are very easily implemented (like aliases) in userland.
All you’d need is a `Math.roundUp = Math.ceil` to start using the code you want.
> On 4 Aug 2018, at 23:55, Eric Andrew Lewis <eric.andrew.lewis at gmail.com> wrote:
> Hi there,
> this is my first message to the list. Thanks for all that you do to improve the programming language for the web!
> This is probably a curious proposal that will go nowhere but I thought it'd be interesting to share a suggestion and see how it goes.
> I suggest introducing Math.roundUp() as an alias for Math.ceil() to provide an easier to read and remember method name. If this makes sense, introducing Math.roundDown() might be a good alias for Math.floor() as well.
> I searched for previous discussions on creating method name aliases and couldn't find one to see how the committee has made decisions about them in the past.
> Eric Lewis
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the es-discuss