New Promise Syntax Proposal

Jorge Téllez novohispano at
Mon Nov 6 15:23:17 UTC 2017

I would like to propose a new syntax for promises for the next ECMAScript.

It is common to define promises in the following way:

function promiseFunction() {
  return new Promise(resolve, reject) {

In the previous example, I am declaring a function so that I can access the promise throughout. 

I would like propose a simpler syntax to remove this redundancy:

promise promiseFunction(resolve, reject) {

This will make the promise declaration easier to read in a similar fashion as the new class syntax made it easier to declare prototypes.

Jorge Téllez
+52 1 81 2567 8257
@novohispano <>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the es-discuss mailing list