Proposal: Boolean.parseBoolean

James Treworgy jamietre at gmail.com
Mon Mar 20 19:07:28 UTC 2017


I'd say there's no clear model for consistenty, e.g. JSON.parse. One could
argue that the template is that anything which has only one way to parse is
to use `parse`. Numbers have more than one way (`parseInt`, `parseFloat`)


On Mon, Mar 20, 2017 at 3:04 PM, Dmitry Soshnikov <
dmitry.soshnikov at gmail.com> wrote:

> On Mon, Mar 20, 2017 at 11:57 AM, T.J. Crowder <
> tj.crowder at farsightsoftware.com> wrote:
>
>> Any reason for not just using `Boolean.parse`? (Rather than repeating
>> `Boolean` in the function name?)
>>
>>>
>>>
> Just a copy-paste from Java, similarly was done with `parseInt` taken from
> Java. But just `parse` probably would work too. For consistency and
> predictability `parseBoolean` is probably better now.
>
> Dmitry
>
> _______________________________________________
> es-discuss mailing list
> es-discuss at mozilla.org
> https://mail.mozilla.org/listinfo/es-discuss
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20170320/c41441c1/attachment.html>


More information about the es-discuss mailing list