Proposal: Boolean.parseBoolean

Dmitry Soshnikov dmitry.soshnikov at gmail.com
Mon Mar 20 19:04:53 UTC 2017


On Mon, Mar 20, 2017 at 11:57 AM, T.J. Crowder <
tj.crowder at farsightsoftware.com> wrote:

> Any reason for not just using `Boolean.parse`? (Rather than repeating
> `Boolean` in the function name?)
>
>>
>>
Just a copy-paste from Java, similarly was done with `parseInt` taken from
Java. But just `parse` probably would work too. For consistency and
predictability `parseBoolean` is probably better now.

Dmitry
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20170320/5384d2b1/attachment.html>


More information about the es-discuss mailing list