ljharb at gmail.com
Tue Jul 4 21:44:03 UTC 2017
To have that be worth a language change, I think you'd have to make a
compelling argument that the performance of Math.min and Math.max, used
together on the same large set of numbers, was sufficiently slow as to make
widely used use cases untenable without your proposal.
I'd be happy to review the results of that research.
On Tue, Jul 4, 2017 at 12:24 PM, Xavier Stouder <xavier at stouder.io> wrote:
> It’s more concise and if you’re comfortable with destructuring assignment
> syntax, I think it’s also more readable.
> Whatever, differents folks, differents strokes. This proposal offer the
> possibility to reduce by two the length of a “get min and max” operation,
> and probably improve the performance of the operation when used with large
> amounts of numbers.
> es-discuss mailing list
> es-discuss at mozilla.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the es-discuss