Math.minmax

Jordan Harband ljharb at gmail.com
Tue Jul 4 18:50:24 UTC 2017


To me it seems like minmax is *less* readable - between repeating the RHS
(with min and max) vs condensing them and having nonobvious LHS syntax
(with minmax), I'd prefer the current situation.

On Tue, Jul 4, 2017 at 8:37 AM, Xavier Stouder <xavier at stouder.io> wrote:

> Even if I think it should be a performance improvement, the main goal
> actually is to improve readability and conciseness of the code.
>
>
>
> When you say “I'd expect it to be something closer to [min, max] =
> Math.minMax(foo, bar)”, are you saying that minmax (or minMax) should only
> take two arguments ? I think that if it’s implemented like this, it would
> obviously be not so usefull.
>
>
>
> Some questions about the proposal process :
>
> -          Are champions reading and commenting this feed ? Can we have a
> comment on this proposal maybe ?
>
> -          Is the purpose of proposals to question how the proposal would
> be implemented by JS engines ?
>
> -          Talking about tests previously quoted : Is an JS
> implementation of this proposal just approaching how efficient (or not)
> would be the proposal after being implemented by JS engines ?
>
>
>
> Thanks for your feedback.
>
> _______________________________________________
> es-discuss mailing list
> es-discuss at mozilla.org
> https://mail.mozilla.org/listinfo/es-discuss
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20170704/831e52d8/attachment.html>


More information about the es-discuss mailing list