it would be nice to have async-blocks like ``async {some_statements}`` and ``async (some_expression)``

Igor Baklan io.baklan at gmail.com
Tue Jan 3 21:33:26 UTC 2017


As I've mentioned in initial post

> this idea "isn't new", something very similar I saw in
[[async-do]](/topic/support-syntax#content-5) comment

So answer yes - it quite the same idea. However as for me ``do`` part is
quite optional and can be omitted without any lost (in this construct).
Meaning that if we will introduce different variations of so called "do
{...}" statement in future, they not mandatory should share ``do`` keyword
(they rather should only share the same "spirit").
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20170103/5533c247/attachment.html>


More information about the es-discuss mailing list