I like the idea of a block level annotation. Lighter and more practical than a new set of operators. Module level would be nice too. OTOH expression level feels a bit like overkill. Why not turn this into a more general _pragma_ syntax then? This would allow us to control other special conditions: throw on overflow, on divide by zero, etc.