Rename RequireObjectCoercible in some contexts?

Axel Rauschmayer rauschma at icloud.com
Thu Nov 26 07:20:57 UTC 2015


I realize that this is nit-picky, but the name `RequireObjectCoercible` feels wrong (and not intention-revealing) in the following context (which is not about objects at all):

1. Let O be ? RequireObjectCoercible(`this` value).
2. Let S be ? ToString(O).

Something like `RequireActualValue` or `ThrowIfUndefinedOrNull` seems like a better choice here.

-- 
Dr. Axel Rauschmayer
axel at rauschma.de
rauschma.de





More information about the es-discuss mailing list