Axel Rauschmayer axel at
Sat Nov 1 20:23:27 PDT 2014 <>

Isn’t the name of that operation misleading? How about the following changes?

* Rename `CreateFromConstructor` to `CreateViaCreateAction`.
* Throw an exception in step 3.

CreateFromConstructor is only used in two locations:

* 7.3.18 Construct (F, argumentsList)
    * Change step 2 so that `CreateViaCreateAction` is called if `F` has a property `[[CreateAction]]` and `OrdinaryCreateFromConstructor` otherwise.
* NewPromiseCapability ( C )
    *  `CreateFromConstructor` being used here effectively means that you must subclass `Promise` (the note sounds like that is desired). `CreatePromiseCapabilityRecord` re-implements the constructor protocol. I’d prefer it if that duplication of functionality didn’t happen and (e.g.) `Construct()` could be used, but that may be too complicated a change.

Dr. Axel Rauschmayer
axel at

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the es-discuss mailing list