Kevin Smith zenparsing at
Fri Jun 27 12:33:00 PDT 2014

>   import {f, g, h} from "url"
>   f(); g(); h()
> or
>   module M from "url"
>   M.f(); M.g(); M.h()
> These should be freely interchangeable -- the programmer shouldn't
> need to pick between getting import checking but polluting the scope
> and making uses less readable, or the other way round. The current
> semantics falls short on that, it doesn't check in the latter case.

I didn't even realize that was the case.

> So from my perspective, that would need to be fixed as well. Which
> would be fairly easy.

I totally agree.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the es-discuss mailing list