New ES6 spec draft (Rev 22, Jan 20, 2014)

Kevin Smith zenparsing at gmail.com
Tue Jan 21 06:29:16 PST 2014


Couple of nits WRT modules:

- The instantiationRequest interface is defined as having two properties:
 "execute" and "deps".  I believe "deps" should be spelled "dependencies"
to match the naming conventions throughout the rest of the document.
 Besides that, there is no reason that I can see to optimize keystrokes for
that property name.

- The loader for the current realm is specified as a property of the global
object named "System".  This has always bothered me for two reasons:

  1) The word "system" does not describe the object.  It is a loader, not a
"system".

  2) The current loader is an instance of the Loader type.  It is
incongruent to name an instance with a capitalized identifier.  I believe
it would be more appropriate to provide access to the current loader via a
getter on the Loader or Realm constructor.  For example:

    Realm.loader
    Loader.current
    etc...


Thanks - it's looking great!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20140121/ca9056e2/attachment.html>


More information about the es-discuss mailing list