The Paradox of Partial Parametricity

Andreas Rossberg rossberg at
Tue May 28 23:59:40 PDT 2013

On 28 May 2013 20:04, Russell Leggett <russell.leggett at> wrote:
> Yes, I had suggested the name "resolveOnce" as I think it really helps
> describe what it does in relation to 'then'. As someone learning for the
> first time, I would likely read that and think, "Only once. That means
> something else resolves more than once." Reading the docs for 'then' and
> seeing the examples, would make it pretty clear to me that 'then' *just
> works* while resolveOnce is more of a low level method.

Neither is more low-level. Also, 'then' with recursive unwrapping does
_not_ work when you want to write generic abstractions properly --
which is why we need the alternative to start with.

Can we perhaps find a name for 'chain' that indicates that it is more modular?


More information about the es-discuss mailing list