Module Loader Comments

Kevin Smith khs4473 at
Thu Mar 14 14:35:45 PDT 2013

> > So it's really more of a "transform" hook than a "translate" hook.  Would
> > naming it "transform" would make the intention more obvious?
> Transformations of languages are translations, so I think that
> `translate` is clearer.  CS -> JS is a translation.

Sure, but to me "translate" implies translation from one programming
language to another.  But the "loader" concept can be fully expressed
without dependence on on the concept of "other languages".  "Transform", to
me, implies the more generic concept.

Anyway, my questions are cleared up (for now).  Can't wait for those wiki
updates!  ; )

{ Kevin }
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the es-discuss mailing list