Object.mixin( source, target ) | arguments changed

Matthew Robb matthewwrobb at gmail.com
Thu Jun 13 10:11:33 PDT 2013


While I like the name mixin, I infinitely like the name define more. Better
still I LOVE this
http://wiki.ecmascript.org/doku.php?id=strawman:define_properties_operator


On Thu, Jun 13, 2013 at 10:09 AM, Kevin Smith <zenparsing at gmail.com> wrote:

>
>>
>> Based on this and the example shown above, I think it's fair to say that
>> reversing the arguments isn't in the ES6's best interest.
>>
>>
> Definitely.  Reversing the argument order would make for awkward code like
> this:
>
>     Object.mixin({
>
>         a() {},
>         b: 123,
>         c
>     }, target);
>
> And I agree that we should attempt to find a different name for "mixin",
> if possible. (although it means I'll have to change my bleeding edge code
> yet again!)
>
> { Kevin }
>
> _______________________________________________
> es-discuss mailing list
> es-discuss at mozilla.org
> https://mail.mozilla.org/listinfo/es-discuss
>
>


-- 
- Matthew Robb
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20130613/6840cffd/attachment.html>


More information about the es-discuss mailing list