`.toArray()` for all generators

Rick Waldron waldron.rick at gmail.com
Wed Aug 28 14:40:07 PDT 2013


On Wed, Aug 28, 2013 at 11:02 AM, Forbes Lindesay <forbes at lindesay.co.uk>wrote:

>  It would be nice from a readability point of view if
> `iteratable.toArray()` could always be used as a substitute for
> `Array.from(iteratable)`.
>

Since both Array.from and [..spread] already covers every single iterable
and arraylike case now and forever, there is very little benefit (none?) in
also specifying a toArray method on the prototype of every object that is
capable of creating an iterable.

Rick
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20130828/a1929146/attachment.html>


More information about the es-discuss mailing list