Killing `Promise.fulfill`

Domenic Denicola domenic at
Tue Aug 20 07:17:39 PDT 2013

Indeed, nice catch Anne. I guess it's an unfortunate necessity that the monadic stuff will need to drag along two methods, not just one.

A name like "unit" (or perhaps "of") seems to fit better in my mind, than introducing another natural-language verb like "accept." Especially since it will be used alongside "flatMap," and ignored by "then" users.

At this point I'd like to have a moment of silence for our treasured and dearly departed friend, "separation of concerns."

More information about the es-discuss mailing list