A Challenge Problem for Promise Designers (was: Re: Futures)
domenic at domenicdenicola.com
Fri Apr 26 07:16:52 PDT 2013
From: David Bruant [bruant.d at gmail.com]
Since this entire problem seems predicated on Claus's misunderstanding of the term "thenable," which apparently has no basis in real libraries but instead entirely in wishful thinking, it might be more prudent for him to use the term "monad" instead of "thenable" and perhaps choose a different name for the method he wants, e.g. "flatMap" or "bind" instead of "then." That seems more aligned with reality than trying to change promise semantics based on some desire to co-opt the word "then" from promise libraries.
More information about the es-discuss