Nannying (was: Array comprehension syntax)
brendan at mozilla.com
Wed Sep 26 11:19:31 PDT 2012
Allen Wirfs-Brock wrote:
> To me, adding let in combination with multiple ifs feels like a significant extension to what was in the original proposal that was accepted for ES6. It seems like the sort of proposal change that should be presented at a TC39 meeting.
Jason did propose (for|let|if)+, see
This was missed when Dave carried things over to the new wiki
namespaces. It has been discussed at TC39 meetings.
Asserting significance won't do. Andreas and I have agreed with Jason
that the desugaring is straightforward in all cases and you haven't
responded directly to that argument. We have lots of detailing to do for
ES6, and this is not out of line with other missed or overlooked
problems in proposals.
More information about the es-discuss