Typo in direct proxy proposal for the apply trap

Tom Van Cutsem tomvc.be at gmail.com
Tue Sep 11 12:19:12 PDT 2012

"receiver" is indeed a bit of a misnomer for the apply trap. "thisArg" is
more sensible. I'll update the wiki page.

You probably missed it, but the role of the "thisArg"/"receiver" parameter
is described by example using the following code snippets on the direct
proxies wiki page:

proxy(...args); // triggers handler.apply(fun, undefined, args)
var obj = { m: proxy }; obj.m(...args); // triggers handler.apply(fun, obj,
Function.prototype.apply.call(proxy, rcvr, args); // triggers


2012/9/3 David Bruant <bruant.d at gmail.com>

> Le 02/09/2012 23:13, Brandon Benvie a écrit :
>  The use of the term receiver is somewhat misleading when put next to the
>> receiver in the get and set traps. For get and set the receiver is always
>> the proxy unless it's an object that has the proxy as its [[prototype]].
>> For function invocation the receiver is the callsite object which is never
>> going to be the proxy itself (unless you did something like
>> fnproxy.call(fnproxy).
> Indeed. I spent some time yesterday playing with the direct proxy Firefox
> implementation and adjusting the Proxy doc on MDN [1] (which is why I
> spammed es-discuss with proxy-related topics).
> I chose not to use "receiver" in the doc, but "thisValue" instead.
> David
> [1] https://developer.mozilla.org/**en-US/docs/JavaScript/**
> Reference/Global_Objects/Proxy<https://developer.mozilla.org/en-US/docs/JavaScript/Reference/Global_Objects/Proxy>
> ______________________________**_________________
> es-discuss mailing list
> es-discuss at mozilla.org
> https://mail.mozilla.org/**listinfo/es-discuss<https://mail.mozilla.org/listinfo/es-discuss>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20120911/6d1fda33/attachment.html>

More information about the es-discuss mailing list